Legends of Yore

Main site: http://www.legendsofyore.com

Applet: http://www.legendsofyore.com/game.html
Android: http://www.legendsofyore.com/android.html
iPhone: http://www.legendsofyore.com/iphone.html

This is the main project I’m working on at the moment. It uses Oryx’s wonderful Lofi graphics again. It’s intended to give the rogue-like experience but without all the button pressing. It’s entirely mouse based and tries to do the logical thing when asked.

It’s still quite early on but you can adventure round, killing monsters, leveling up and getting items. There is also a surprise or two along the way. You’ve got options on who to play and how to develop the characters, hopefully its a bit fun if not massively yet. You start out in town at the moment but can’t do much there, best to get straight on into the dungeon delving. Town portal spells exist so you can always get back if needs be. The game is loosely based on Diablo game play so expect to see some more ideas stolen as it develops.

I’d be interested in any feedback at the moment, but specifically towards UI and interface. The game is intended to play very quickly letting you get as much adventuring done on the bus as possible. Any sort of crashes etc would be appreciated.

There’s a lot of info on the website, but not linked yet is the rules document. You can find that at:


For those of you more into roleplaying this sorta outlines how the game plays, it’s going to be updated with a couple of new features next but any feedback directly on the rule set would also be most welcome. I’ve also got a game play guide to write so hopefully there will be help available for those who can’t work out how to use the current interface.

Thanks to anyone that has a go and for any feedback,


Fun so far. Been playing it for a little. Game crashed after I was killed by a snake. Although I reloaded my saved game and it was fine than. I like the way you attack monster’s. I really enjoy this game a lot actually.

Edit: Another thing I found out is if you enter a room with two monster’s and you attack the monster in front of you when your in the door, it kill’s the other monster next to it some how. Doesn’t happen all the time though.

Thanks for testing! Did you happen to get a stack trace from the java console for the crash?


Exception in thread “Thread-12” java.lang.RuntimeException: Attempt to set location before actor is on map!
at org.newdawn.touchquest.data.common.Actor.removeFromMap(Actor.java:451)
at org.newdawn.touchquest.data.map.Map.removeActor(Map.java:442)
at org.newdawn.touchquest.data.map.Map.checkForDeadActors(Map.java:715)
at org.newdawn.touchquest.data.Model.update(Model.java:97)
at org.newdawn.touchquest.game.DungeonTab.logic(DungeonTab.java:52)
at org.newdawn.touchquest.game.TouchQuest.logic(TouchQuest.java:99)
at org.newdawn.touchquest.game.TouchQuest.update(TouchQuest.java:87)
at org.newdawn.touchapi.applet.TouchApplet.gameLoop(TouchApplet.java:134)
at org.newdawn.touchapi.applet.TouchApplet.access$200(TouchApplet.java:38)
at org.newdawn.touchapi.applet.TouchApplet$1.run(TouchApplet.java:74)

Thats fantastic, thank you!


No problem! Glad I could help!

I played around a little but now my boss arrived so I can’t keep playing :frowning:
From what I’ve seen it’s quite … roguelikey !
I think the controls work nice (at least with a mouse) but I don’t know about the precision on handheld devices . Maybe it will be a bit frustrating for the large-fingered people , but maybe I’m being a little pessimistic here .
Are you using your Dungeon Generator ? I am myself working on a sort of rogue like and will soon start using it !

How do you handle saved games without signing the applet ? cookies ?

All in all, good work, as always !

Cookies to save, and yes dungeon generator code is very similar - though it’s been improved a bit recently.

Re: Touch screen devices - the game actually attempts to guess which square you meant when you touch - so if your fingers are a little fat it should help you out a bit at least. I play it on phone and tablet and it’s pretty comfy.


Are you using xmlvm to cross compile?

Yep, my 3 games at the moment (and another one I’m just starting) are using XMLVM to build the java into iphone land. Slightly different api I used compared to last time - smaller and more automatic.



There was a snake and an oger, and at one point boom, that wierd square poped up. Is it normal ?
Doesn’t really seem normal

edit: cool game otherwise :slight_smile:

Believe it or not, it is normal - just a graphics screw up, thanks for the report! :slight_smile:

Just uploading the fix, what should happen is the walls collapse and leave rubble on the floor (the ogre smashes through walls to get to you :))


Don’t know what you’ve changed since this morning, but two comments from when I tried it twelve hours ago:

  1. Can you put a marker on your map when you discover where the stairs down is?

  2. ‘Level’ bar on the left compares your TNL (Till next level) against your total exp against your instead of only showing the percentage of your TNL. Meaning once you hit level 2 (and every level after that) the bar goes to 100% and then resets again at 50%.

Looks great though, love your site. cokeandcode was the site that gave me the drive to start relearning java with game programming in mind. (Followed a tutorial link to cokeandcode off of gamedev.net and ultimately found JGO due to it)

Got to level 3 before dying. Then I noticed that when you were dead you could still use potions to regain health. And when I tried to fight something or move I got a similar crash to Azulon:

Exception in thread "Thread-12" java.lang.NullPointerException
	at org.newdawn.touchquest.data.common.Actor.setTarget(Actor.java:144)
	at org.newdawn.touchquest.game.DungeonTab.processTileClick(DungeonTab.java:206)
	at org.newdawn.touchquest.game.DungeonTab.mousePressed(DungeonTab.java:193)
	at org.newdawn.touchquest.game.TouchQuest.mouseUp(TouchQuest.java:211)
	at org.newdawn.touchapi.applet.TouchApplet.gameLoop(TouchApplet.java:125)
	at org.newdawn.touchapi.applet.TouchApplet.access$200(TouchApplet.java:38)
	at org.newdawn.touchapi.applet.TouchApplet$1.run(TouchApplet.java:74)

Tried the game, found no bugs (made it to level three or four), and enjoyed it much
I especially like the balanced design for a rather small game like this: just start playing with no long set of complicated rules but an intuitive controlling. Keeps the frustration level low at the beginning. If you go on an evolve it, i would let other items that apples and weapons introduce step by step as you go further down the dungeon.

Also very clean programming i think.

(Went on to lvl 6)

GUI was fine and intuitive
The game was way too easy but I guess that’s the point for now for testing
Once going down 6-7 ish levels I got teleported back to town when going down a stairs and then every time I went down I came to the first level and every time I completed the first level I came back to town.
I tried dying and that’s bugged (bag got filled with swords, could heal myself and kill the one who had attacked me)

I guess you know where you’re going with this but making it a bit harder and adding content to the stores and so on will make it quite nice. Oh, and I liked the miniboss, looked neat :slight_smile:


I used to play this a lot with a friend of mine. It is great fun, but we got a little stuck with the amount of content available at the time, and the fact that saving would make your items disappear :stuck_out_tongue:

Still working here, built a little tool to make content addition easier:



Looks to be shaping-up nicely.

Some comments on the user interface (having played the applet version of the game):

  • I didn’t find the buttons at the start of the game intuitive (warrior, archer, etc.). I stared at them for a couple a seconds before realising that I was probably supposed to click one. Maybe if their borders flashed in turn (or something) it would be more obvious that they’re waiting to get clicked.
  • The “skip turn” button still works when on the inventory/map/etc. Is there a reason for it to appear at all on those screens?
  • How about highlighting the destination tile (or target monster) while the player is walking there? Given the blockiness of the scrolling, that might make it easier for my poor eyes to track what’s going on.
  • I’m sure that providing some more visual feedback when a monster dies is on your to-do list. My vote goes for it moving up the list a little.
  • One way you could maybe speed the game up a bit: allow the player to click on a room on the map to walk straight there (monsters allowing).


How about having the “path” that will be followed being displayed while moving the mouse?