Boulder Dash 4k

This is my entry for J4K 2010 competition.

This is my initial attempt of fitting the 1980’s classic into 4096 bytes.

Navigate RockFord through 20 caves, avoiding fireflies and falling boulders, collecting diamonds and squishing butterflies in order to acquire sufficient diamonds to open the exit to the next cave.

I have tried to keep the game play as close as i could to the original, however, I have had to make compromises and have deviated from the original in the following manner:

  • no sound… which is a little sad but fitting the original graphics and original 20 levels is already a tight squeeze… putting in theme music and sound effects goes over the 4k budget enormously…
  • no title screen and thus no ability to start at different caves.
  • unlimited lives… I have removed the original set number of lives and instead went for a score penalty for dying. If you die or time runs out you will restart the same cave you are on. In this way i hope to compromise for the inability to start at different levels.
  • only one difficulty setting.

CALL FOR TESTERS :slight_smile:

Could people please attempt to play the game and give feed back?


  • does it work on your platform? (linux, windows (all flavours), mac)
  • is it too difficult? too easy?
  • any bugs… i mean features spotted? :stuck_out_tongue:
  • any annoyances or simple features you would like to see which would make it a better game?


Runs on Linux 64-bit, Java 1.6.0_15. Irritating flickering at the top - looks like it draws the text over the map, and occasionally shows the map for one frame rather than the text.

In terms of difficulty, I’ve just given up after failing level 3 for the fifth time. I once managed to collect all the diamonds, but had only 12 seconds left to search the entire map for the exit.

Oh, and pushing sometimes takes quite a bit of patience. I tried pushing on the first level, found it didn’t work, and only tried again because level 2 was clearly impossible without it.

I get the flickering too; intel graphics, windows xp, 1.6.0_16-b01.

Apart from that it runs fine on my netbook - did have one strange occurance where the game stopped responding to key input for a while, but not sure what the cause was, and cannot replicate it.


hmm… bugger about the flickering… It does not show on winXP java 6_17… I will have to draw to a single image and then blit it instead of blitting the text image and map images seperately. I hope i can fitt it in!

Re pushing I can increase the likelihood of rock pushing… maybe 50/50 would be sufficent.

yeah, level three is quite difficult… i might reduce the numer of diamonds needed to 3 instead of 4.

Plays well, although I’m getting killed occasionally for some reason I haven’t figured out yet. Text flickering occurs occasionally and can get quite severe. Intel GM45 graphics, Core 2 Duo , W7.

I will attempt to fix the flickering when i get home from work.

Let me know if you can reproduce getting killed with out reason (i.e. boulder falling or enemy) as that sounds like a bug to fix!

java.lang.ClassNotFoundException: read.class
	at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$ Source)
	at Source)
Caused by: open HTTP connection failed:
	at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
	at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
	at sun.plugin2.applet.Applet2ClassLoader$ Source)
	at Method)
	... 7 more
Exception : java.lang.ClassNotFoundException: read.class

With firefox and IE, Java 1.6.0_13

Or time. That might be the one he missed.

updated :slight_smile:

-I have hopefully fixed the flickering… can Abuse or pjt33 confirm or dash my hopes :stuck_out_tongue:
-boulder pushing now 50/50 chance
-reduced the number of butterflies needed to kill in level 3 from 4 to 3 to make it easier.

re: bonbon-chan… i have been uploading some broken versions while making this update… please try again now :slight_smile:

re: pjt33… ah yes… time… the silent killer! catches up on you.

Flickering sorted :thumbsup:

Gotta say I remember this game being much better than it actually is =)
Nothing against the quality of your clone ofcourse!
Just the fondness of memories clouding objective judgement - and perhaps we’ve gotten used to games being much easier & less frustrating ::slight_smile:

Work fine now :wink:

Yeah, flickering’s fixed. Can anyone confirm that there is an exit on level 3? It’s driving me nuts.

I never played the original. I played a game on the Amstrad which was probably identical gameplay but had much better graphics. Can’t remember what it was called, but it was themed around squirrels.

Flickering is fixed. I’ve found out what’s killing me. If I dig vertically next to a boulder and keep digging down, the boulder moves across above me and then falls down. I figure this is intended and that digging down twice next to a boulder is a no-no.

boulders will “roll off” other boulders and brick wall so yes, if you dig vertically down next to two boulders on top of each other then the top one will roll on to you and squish you :stuck_out_tongue:

That is good news!

I think the keyboard lets it down as a controller… the joystick was better for this game. But yes nostalgia does gloss over the bad bits. It is like playing bubble bobble… not really that enthralling!

Normally the exit is in the bottom right of the map in the surrounding border… i.e. not a stand alone exit.

I likewise had an Amstrad. I played the amstrad port of the game. I was actually considering to make Fruity Frank which was bundled with the amstrad cpc 664 but i dont think there would have been as big an appeal to the wider audience. I personally found fruity frank to be more intense/fun.

I think the game needs a pause button… I will have to scrounge around for a few more bytes to allow this… it is getting very difficult to find some spare bytes!

There’s a Jagex game in this genre (Crazy Crystals, on the Funorb portal) which uses keyboard and it feels like the right controller. But then I haven’t used a joystick for about 10 years, so I’m used to keys for everything.

Wait, did they really fall off walls in the original? I remember them falling off diamonds and boulders, but I thought dirt and walls were safe.

Anyway, this is super faithful and great fun. =) Very nice job!

yep, the boulders do not roll off:

-Rockford (you) and enemies
-Magic Wall (looks like a normal brick wall until activated and then converts boulders into diamonds)
-Steel walls
-Blank spaces

leaving the boulders (and diamonds) to roll off of:

-brick wall

Thanks for the compliment. For a “simple” game it is actually quite complex to program! It has been a challenge to program it for minimum size and to keep it semi-understandable!

I think i might make a cave editor so that people can make their own levels :slight_smile: