Bend Hero

In an alternate reality wires are placed on to circuit boards by nano-creatures called benders - thats you. Your job is to bend the wires to match the circuit designs provided by the mighty engineering gods. Each design must be matched within the requried accuracy level for you to be considered the highest grade of bender, Bend Hero!

Your bender will move along the wire. At the right time, use the cursors, or left/right mouse buttons, or on screen buttons to bend the wire clockwise or anticlockwise to match the template.

At the title screen you can select different levels using the bending controls. If you want to quite during a bend press escape or click “Give Up”

Feedback and votes (either way appreciated). It was a rush job due to a lack of time. I’ll post the android version soon.


Fun and a nice progression of levels, turning with the arrow keys can be difficult because it’s so slow, but I guess that’s the point.

Well…just great! Good job…

Thanks for the positives guys :slight_smile:

I considered making the rotation speed up as the levels go (like the movement) but it made it pretty close to impossible. As it stands if you can complete all 10 levels you’re doing very well :wink:


Did you forget to sign it? I get an AccessControlException in JavaSound. without seeing a security dialog at any point.

You don’t need signing to access JavaSound. There shouldn’t be any signing required for the app :confused:

Could just be version of Java I spose, not sure.


Hmm. Tried in a different browser and it works fine. Must be a weird issue with Konqueror’s Java plugin, because it’s supposed to defer to the same (Sun) Java install as Firefox.

This was fun, although I didn’t quite “get” the scoring system. Sometimes my bend would appear to be quite wacky and I would still be awarded a good score.

Cool and fun , just a little too hard :wink:
seems to me a very well polished game for 48 hours.
congrats !

Not that thumbs down are a problem, but could I get feedback to help improve future attempts :slight_smile:


Havent voted so can’t comment here…
Just played… Simple game but strangely addictive… I found myself compelled to complete all 10 levels…Level 10 was frightening but managed on 2nd attempt (was pleased with 98.6% on Level 6)…

really good use of the theme.

found it challenging aswell. nice work

Great fun! And very impressed that your converter can generate an Android version. Will be keen to see it.

Now with free android version:

Not sure whether to stick in on market yet, anyone test it for me?


For sure you know live-android!?

Just found it today,…maybe I will try it in a virtualbox!


Yeah, tried it in a virtual box, it was fine and super fast. It’s pretty limited in terms of using for testing at the moment tho, the app deployment stuff is pretty hard work.

Back to Bend Hero - I’m going to be extending and polishing this one for release to Android and iPhone.

Hence, I’d still really appreciate feedback and suggestions on how to improve, extend and tailor the game for a wider audience.



Just gave it a go on the HTC G1. Not so good. The log went crazy with:
08-07 23:16:45.167: ERROR/GLLogger(10399): called unimplemented OpenGL ES API

It didn’t run nearly as smoothly as the PC. I’ve also attached a screen shot of when the game ended.

Interestring. The screenshot is an issue I’ve fixed locally where the GL resources get released but Canvas carries on using them (at least I think it is). However, this bit

called unimplemented OpenGL ES API

I have no idea. I don’t actually call very much OpenGL ES directly, I use the Canvas backed by GL and call that. Could be just noise - does it render normally?

Speed wise, it’s definitely not as smooth as the applet even when it is working properly, although again locally I’ve fixed alot of speed issues with your suggestion, and some more about loading opaque textures in the right format (the background for instance).


Thinking about it, you’re on 1.5 are you?

EDIT: also might be a firmware issue.


Confirmed on another G1. How irksome!

The white bars you’re seeing should be black alphaed blocks with outlines I think. Then some text written across which is evidently failing.

I’ll hack up a different version tonight if you don’t mind testing again