Wizzy 4K

NOTE: this game has been updated. Be sure to remove cached applets if your game does not look like the screenshot (start / control panel / java / general / settings / delete files) -> silly Oracle…

My third and final entry for this year’s Java4K: Wizzy 4K!

Wizzy, like most students, didn’t pay attention in the boring dark magic classes. Which is a pity, because one of his fellow students did. And he took over the University, turning all teachers and students into green slimy monsters! (while Wizzy was taking a nap) Not knowing any offensive spells, Wizzy has no chance of beating the Evil Guy. Not that he wants to anyway, he just wants to get out! The only spells Wizzy knows are gravity inversion spells, which he thought were rather neat. Help Wizzy get out alive using these spells!

[applet archive=wizzy4k.jar class=W width=512 height=532]

(also on the Java4K website, and my website)

Instructions: reach the door out of each level room while avoiding the monsters and spikes.
Press space to start the game.
Move and jump using the arrow keys.
Z = cast inverse gravity for self spell,
X = cast inverse gravity for others spell.
To cast a spell you one mana crystal, which you need to collect (the blue balls, collected crustals are shown in the bottom-right).
Press R to restart the level.

Wow! That’s nice! I like the graphics ;D
And the gameplay also.
Good work!

This looks fantastic. There is absolutely no feel of something missing despite the size restriction. Game-play is nice, graphics and sound really go well together.

Well done.

Hmm everything was awesome minus the horrendous FPS… I feel like I was getting 2 FPS =/

Thanks ;D

Good point, I’ll see if I can improve the performance.

Hm. Looks pretty smooth to me… ok, maybe its because of my computers at home and at work, both are Core i5…

That reminds me of testing my humble entry (Fuego) on slower machines…

Yeah, I was kind of fooled by the smooth performance on some machines as well. But it turns out @ClickerMonkey was right: there is a weird bug in the timing code (which should make sure that the delta each update is not too large, to avoid collision detection issues). On some machines it makes things stutter a lot. Fortunately I have found a way to fix this, and I will update the jar once I have some hobby time again ;D

This Wizzy 4K is looking very nice and seems to be a fun game. Unfortunately, controls were really terrible with my AZERTY keyboard, so I haven’t been able to go very far.

Here are my specs:

Alienware M14x
Intel Core i7-2630QM CPU @ 2.00 GHZ
6.00 GB Ram
Windows 7 64 bit

Nice retro-graphic look and I like the promised gameplay. Unfortunately I can’t move - well I managed one move. 1.8GHz i5, OSX, Java 7.13.

Very elegant presentation and mechanics

I’ve simplified the timing code a bit, and hopefully this will resolve the performance issues. On my laptop (Win 7 / i3 processor, nothing special) I can run 4 instances simultaneously with no problem. I’ve also fixed some very minor bugs and tried to make the code a bit more robust. However, I could not find an issue that would prevent you from moving. I also managed to squeeze in a stack trace print instruction in case of exceptions, which may make resolving future issues easier.

I tried both the applet here and on Java4k.com. Both seem to lock up after one move. Pressing Reset works 100%.
Edit: I suppose I could have the old one cached… but no, I hadn’t played the Java4k version before, so that can’t be it.

Edit: I consistently get one move after a restart. It looks like no further moves are recognised. It might be something weird with the Java/Safari interaction.

I f*****g loved it. The sound and gfx are amazing, love the simple gameplay too. No FPS or running issues.

BUTTT… whats the deal with jumping? Do I have to come to a stop or be below a certain speed to jump? Feels so hit n miss. Also room 4, what do I do?

Cool game! I beat all 5 levels, I wish there were more :slight_smile:

It’s really good.

Ok, thanks for the feedback. I might be able to figure out more knowing this (maybe something weird in keyboard handling approach).

Another update! Here’s the changes:

  • tuned level 4 difficulty a bit (its easier now)
  • one additional room, there are 7 rooms now
  • a new background
  • using a more standard keyboard handling approach: I hope this has some effect on the Mac issues.
  • changed the controls (see the instructions) to suit people with AZERTY keyboard schemes also ;D

Room 4 is a bit easier now, it was too hard to time the first jump right. Also, jumping does not work if you are on (or slightly beyond) the very edge of a platform (which is intentional -> at the edge it is too unstable for Wizzy to make jumps).

I’m sorry to report still no joy on movement. Now using cursor keys I get one move. ‘R’ always works. No errors in console.

Edit: Tried it on my PC, where it works fine, so I’m not missing out. :slight_smile: Very smooth and jump distance is just right.
I wonder whether the timer granularity is different on the two machines.