Option 1
int x = getX(),
y = getY(),
z = getZ();
Vector v = new Vector(x, y, z);
Option 2
Vector v = new Vector(getX(), getY(), getZ());
I personally prefer option 1. Code is harder to read if more than one method is called in the same line / statement, unless the code is really short. However, I cannot say that I enjoy the longer code. Really makes me wish java had C#'s properties.