Use emulated iOS for compiling?

Has anyone tried compiling for iOS on an emulation?

I’m on Windows10, would be loading the Oracle tool, then attempting to load JDK 9 or 10 or better on top of that in order to compile using JLink.

Oracle’s VM VirtualBox installed, and a 64-bit Mac OS “machine” installed.

Hitting a big “now what?” LOL.

I want to get some sort of browser installed and working. Can this be done from the command line? (Goal, to download OpenJDK 10.)

Download the install file to Windows and then find a way to bring it to the VM?
More stuff to learn.

To be continued…

Slight tangent but how do you get MacOS on VirtualBox working?

Cas :slight_smile:


All I see is a cursor that says:


Was working at the music store today and probably heading to SF tomorrow for the database contract. Wednesday should see some progress on this.

My Mac-contractor friend was scratching his head, too. Especially at the part that LS elicited the error message “no drive specified” or something of that ilk.

My guess is that taking a look at the Virtual Machine’s instructions pertaining to the Mac OS might be helpful. (RTFM!) Ever the optimist. :slight_smile:


That could be because of EFI. VirtualBox by default enables EFI to be able to boot the Darwin kernel. However, you can use an alternative like Clover bootloader and disable EFI.

Install Clover into another bootable medium, and add it as a disk device in VM. It should be able to boot from it.

I just found this. Looks promising.

There are a number of other tutorials, as well.
Also, there is a term for this setup (Mac OS on PC): “Hackintosh”.

Download of the OS is supposed to be huge, so I’m going to launch that and head to bed.

V. interested to know how you get on - I’m all but giving up on my actual Mac hardware (2012 Mac Mini) - despite plonking 8GB RAM in it and a half-terabyte SSD it’s still beyond awful to use. And I only want it to compile Steampuppy natives and test a couple of games. I’m >.< this close to giving up on Mac support for good.

Cas :slight_smile:

It’s not looking good.

The tutorials for making a “Hackintosh” via VirtualBox make it seem like this should be a straightforward process. There are certainly a lot of “thank you’s” and “works like a charm” comments.

But there are also quite a few problems that have gone unanswered, including the issue that came up for me.

Possible reasons:

  1. AMD systems are just too different, require a lot more hacking to get them to work;
  2. I did something dumb like assigned more RAM than available (but I can’t test this until I rebuild and check log files–I discovered this solution and answer at the VirtualBox forums after deciding to wipe and restart).

I found a forum dedicated to AMD-OSC. I put an intro post there to kind of sound things out. I don’t think I want to invest a week trying to get this to work.

Article last updated 2016: Is your PC Hackintosh compatible?

**** EDIT 1:
Same error. Also, checked the log for the cmd values that were added, and that assigned ram and cores were all okay values. Yes, probably an issue with AMD cpu.

But if you have an Intel machine, seems like it should work.

**** EDIT 2:
I’ve seen enough now, that SHC’s comment almost becomes comprehensible to me. A number of AMD-related sources mention the Clover bootloader.

[quote]Install Clover into another bootable medium, and add it as a disk device in VM. It should be able to boot from it.
I am slowly starting to understand this. There was a video that talked about putting a bootable something on a thumb drive. The tutorial was four videos long, and I didn’t stay very long watching. Instead, moved on to look for other solutions. Will try and backtrack and look at it again.

I got a recommendation to check the following out, from the amd-osc community.

“This has been the best tutorial for my own experience.”

****EDIT/Progress report

I’ve made what seems to be a working boot USB for High Sierra. Some interesting adventures along the way. The most confusing (second after trying to find the right “.dmg” file) was that when the TransMac program successfully puts the image on the USB, the USB is no longer recognizable by the PC, and messages about formatting the USB start to pop up. These have to be ignored. First pass, I didn’t and as a result had to repartition the very confused USB.

Am now dealing with my Bios editor being very different from the ones shown in tutorials (usually ASUS, mine ASRock and coming on four years old). Questions have been posted at the tutorial about translating to the ASRock version. There’s a lot to figure out still.

****EDIT/Progress report 2

As a step along the way, I’ve just removed the Ubuntu dual boot and Gnu Grub. (And I didn’t hose my system in the process!! ;D ;D ;D ) The system is 100% Windows 10 now. This should simplify things going forward.

This has been a long overdue. I ran out of space on the Ubuntu partitions several years ago, and stopped using it. I’m now wondering if the VirtualBox will run a Linux-based Java JDK. The main point is to compile and test, not develop.

Is your system UEFI or BIOS only? BIOS is older, and IMO most computers coming after 2016 are UEFI only. And coming to the changes to be made, on ASUS or Gigabyte motherboards that I owned before, it was enough to disable Secure Boot and set the Hard disk access mode to AHCI.

And believe me, it’s the AMD processor that makes installation of hackintosh harder. I believe you have to replace your Darwin kernel with something else which is patched with AMD support. Couldn’t help you there as I never owned an AMD processor. Maybe depending on your GPU, you might need a GraphicsEnabler kext as well.

My system is UEFI.
The source for the kernel was this link:
I chose “High Sierra” and the downloaded file, now loaded on the thumb drive:
As far as I know, this is what the AMD-MAC community recommends, and the tutorial I’m following is set up for this.

I thought I had more time, but have to pull away again. Next post will be about the UEFI changes. The other day when I worked through this, I was able to get the system to boot from the thumb drive, but the Mac system didn’t go into its install screens.

Since then, I’ve gotten rid of Grub and the Linux partition on my system. Hoping it all goes smoother this time.