SubPar submitted!

YAY! :smiley:

I have finally manged to squeeze it all into the 4k. Unfortunetly some nice features and more colourful sprites had to be stripped to get it to fit… but it should still be a reasonable contentor.

My main down fall i can see is that I have have very little actual game time to make sure the game plays well, i would like to hear opinons on whether it is too hard/ difficult etc.

I will be uploading the source tomorrow after i have cleaned it up a little and added comments.

Your game is really great! very nice graphics.

Three things:

  1. Link to the source code is not working
  2. The offline version is above the limit of 4096 bytes. I have downloaded it now and it is 4323 bytes so you have to try to shrink a little bit more otherwise it will probably not be judged? Am I right?
  3. It is generating an error: java.lang.ClassCastException: java.awt.ComponentEvent at a.processEvent(Unknown Source). Although the game is still playable.
  1. yep, i will be posting the code today.
  2. only one of the versions needs to below the 4096 barrier, the webstart version is below that barrier, the executable jar is over that due to the meta-inf directory
  3. hmm… thats an interesting one… i have not see that error… but if it is not causing any problem then i will leave it as a “feature” :slight_smile:

I am playing this game on linux and noticed an error.

First off, the game is great, and the difficulty seems balanced.

The error has to do with simultanious buttons being pressed. I can press Up+Left and go go NE, but no other combinations will work. So I only have N, NE, E, S, W.

Great game!

Thanks, it is good to know that it works great on linux, i dont have access to a linux box so i could not test it. Any Mac users out there?

that is the weirdest thing! there should not be any issue with the key board combinations! for key board input i am simply populating an array with the keys pressed. this is my key press listener:

    final protected void processEvent(AWTEvent e)
    	if (((KeyEvent)e).getKeyCode() == KeyEvent.VK_ESCAPE) System.exit(0);
    	key[((KeyEvent)e).getKeyCode()] = e.getID()&1;

I wonder if this is a linux specific quirk? do you have access to a windows box? do you have the same problem?

Good game. Very nice graphics.

When I try to pick up a power up(the yellow one) I get the following:

java.lang.ArrayIndexOutOfBoundsException: -1
at a.(Unknown Source)
at a.main(Unknown Source)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.sun.javaws.Launcher.executeApplication(Unknown Source)
at com.sun.javaws.Launcher.executeMainClass(Unknown Source)
at com.sun.javaws.Launcher.continueLaunch(Unknown Source)
at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)
at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)
at Source)
at Source)

hmm… i think i know what that is… it is proably not due to the power up per-se but every time you are hit by enemy fire, your power up leveling is reduced by one so if you do not have many power ups and then get hit alot it is possible to go into the negatives… that is a bug i did not pick up :frowning:

hope fully it will not effect too many people (or encourage them to get more power ups and hit by enemy fire less :wink: )

I tested it in windows, and the problem was not the same. I had all directions unless the space bar was pressed. I had similar trouble with Choppacide. I would up adding the “F” key as an alternative fire key and that cleared it up. In Choppacide I tried Shift, Cntl, and Alt, and it behaved the same as the Space Bar. There is either a java error with the arrow keys, or with the control keys.

When the space bar is pressed in your game, I have these directions in windows. “N, NE, E, S, W, NW”.

I will be back in a little bit.

Here is my key handling code. It seems to work well on most platforms.

public void keyPressed(KeyEvent e) {
		// System.out.println(e.toString());
		// TODO Auto-generated method stub
		if(e.getKeyCode() == KeyEvent.VK_UP)
			verticle = 1;
		if(e.getKeyCode() == KeyEvent.VK_DOWN)
			verticle = -1;
		if(e.getKeyCode() == KeyEvent.VK_RIGHT)
			rotation = 1;
		if(e.getKeyCode() == KeyEvent.VK_LEFT)
			rotation = -1;
		if(e.getKeyCode() == KeyEvent.VK_F || e.getKeyCode() == KeyEvent.VK_SPACE)
			fire = true;
		if(e.getKeyCode() == KeyEvent.VK_ENTER)
			button = 1;
		if(e.getKeyCode() == KeyEvent.VK_ESCAPE)
			button = 2;


	public void keyReleased(KeyEvent e) {
		// TODO Auto-generated method stub
		if(e.getKeyCode() == KeyEvent.VK_UP)
			if(verticle == 1)
				verticle = 0;
		if(e.getKeyCode() == KeyEvent.VK_DOWN)
			if(verticle == -1)
				verticle = 0;
		if(e.getKeyCode() == KeyEvent.VK_RIGHT)
			if(rotation == 1)
				rotation = 0;
		if(e.getKeyCode() == KeyEvent.VK_LEFT)
			if(rotation == -1)
				rotation = 0;
		if(e.getKeyCode() == KeyEvent.VK_F  || e.getKeyCode() == KeyEvent.VK_SPACE)
			fire = false;

Unfortunetly I cannot include your better cross platfrom keyboard handling… it brings me over the limit… maybe next year?

Also the source code is now available!

There are several things I would like to change about java due to cross platform issues. One would be its lack of control over input devices. We should be able to decide if we want the native feel, or if we want the keyboard and mouse to behave differently than on the host OS. (sounds error prone :slight_smile:

The other would be distribution issues. Webstart is only good for smaller applications, and an executable jar simplifies nothing on most platforms. Neither help with file path problems.

hmm. maybe it is your key board? i know on an older laptop keyboard i had it would not allow certian 3 key combinations…

It could be, I have cheap one. It could also be the way the mother board handles the keyboard? Maybe someone else can test this and reply.

really nice game! I love the background stars and the simple, but very cool explosions…
It’s super fun, when you got 3+ power-ups… And you shoot in every direction! I

I also got the error, when I picked up a power-up. I guess I should have read your advise before I played the game… :stuck_out_tongue:
In one of the games I also flew the ship outside the screen, but I just flew it back, np…

And you even released the source code…

very nice :smiley:

glad you guys have enjoyed it :slight_smile:

yeah, i was quite surprised how effective the explosions (expanding circles with colour fade) worked out.

The main problem is that i was unable to play test it… at all really… so it may be too difficult and some other bugs are probably lurking around as well.

That source does not have the graphics… i will have to upload them.