Rocky - the illegal pool jumper

Ok…finally I got finished. May I present:“Rocky-The illegal pool jumper”

Try to bend down the pole and with getting more than 1100 points (not as said 1000 in the ingame-instructions) you will make it to the other side :smiley:

I hope the applet is working for everyone. It is tested on Windows XP with Java6. At my home computer it is only working in internet-explorer!? At the office even on firefox. Let’s have a try:

download: (4mb)
(Due to some problems with the applet version I was allowed to upload a not modified standalone-version)

Have a nice day, ToM

1802 to beat :smiley:

Loaded fine, looks really interesting. What am I sposed to do, i press left/right ctrl when I’m told and the little bar bends down… but nothing else?


Needs alternative keys for people with laptops.

With little bar you mean the pole!? Or the time-bar?

Well,…yes the game is just about reaction! The faster you hit the key you should the more points you get!
And only if you get more then 1100 points Rocky will make it to the pool! I know,…not the burner but hey I
had only 10h time… :smiley:

oh,…I will fix that after work! Didn’t take that in account!

That’s great for 10 hours work.
Seemed not to respond quick on some key presses, so I had to press the key twice or hold it down.
As always with this sort of game the best part is launching him into the wall ;D

Hm, didn’t run on Safari or Firefox, Mac OS X 10.5.7, Java 6.

Hmm,…I had some problems with my firefox (windows) as well. If it is ok with the rules I will release the game as download without changing the code!?

Hehe…yes, most of the time was used for that animations! I’m always quite good in finding the wrong priorities. But for me the games is okay although in comparison with the game-masters’ blockbusters it has not much gameplay :smiley: .

Yeah go ahead and put in a downloadable version, just make it on your honor that it’s the same.

Of course,…I’m still much to tired for changing anything! The only task for today is watch football on tv (fortuna duesseldorf-hsv) :smiley:

Here is the link: (4mb)


Usage: java [-options] class [args...]
           (to execute a class)
   or  java [-options] -jar jarfile [args...]
           (to execute a jar file)

where options include:
    -d32          use a 32-bit data model if available
    -d64          use a 64-bit data model if available (implies -server, only for x86_64)
    -client	  to select the "client" VM
    -server	  to select the "server" VM
    -jvm	  is a synonym for the "client" VM  [deprecated]
    -hotspot	  is a synonym for the "client" VM  [deprecated]
                  The default VM is client.
    -cp <class search path of directories and zip/jar files>
    -classpath <class search path of directories and zip/jar files>
                  A : separated list of directories, JAR archives,
                  and ZIP archives to search for class files.
                  set a system property
                  enable verbose output
    -version      print product version and exit
                  require the specified version to run
    -showversion  print product version and continue
    -jre-restrict-search | -jre-no-restrict-search
                  include/exclude user private JREs in the version search
    -? -help      print this help message
    -X            print help on non-standard options
                  enable assertions
                  disable assertions
    -esa | -enablesystemassertions
                  enable system assertions
    -dsa | -disablesystemassertions
                  disable system assertions
                  load native agent library <libname>, e.g. -agentlib:hprof
                    see also, -agentlib:jdwp=help and -agentlib:hprof=help
                  load native agent library by full pathname
                  load Java programming language agent, see java.lang.instrument
                  show splash screen with specified image
-bash: libs/jinput.jar: cannot execute binary file
-bash: libs/jme.jar: cannot execute binary file
-bash: libs/jme-ogrexml.jar: cannot execute binary file
-bash: libs/jme-awt.jar: cannot execute binary file
-bash: libs/jme-game: No such file or directory
-bash: libs/jme-model.jar: cannot execute binary file
-bash: libs/lwjgl.jar: cannot execute binary file
-bash: libs/lwjgl_util.jar: cannot execute binary file

That’s after cd-ing into the rocky directory, and getting rid of an extra semicolon you had.

Well,…ok! I made the linux batch blind (cause I had no linux working at the moment) and that was the problem! Linux uses : as seperator instead of ;

Ok,…that’s it for me! It was a pleasure to compete with the best! Next time I will get minimum two thumbs up! lol


Even when I do:

java -Djava.library.path=./native_libs -classpath libs/rocky.jar:libs/jinput.jar:libs/jme.jar:libs/jme-ogrexml.jar:libs/jme-awt.jar:libs/jme-game states.jar:libs/jme-model.jar:libs/lwjgl.jar:libs/lwjgl_util.jar org.tomtro.inpool.Inpool

It gives me:

Exception in thread "main" java.lang.NoClassDefFoundError: states/jar:libs/jme-model/jar:libs/lwjgl/jar:libs/lwjgl_util/jar
Caused by: java.lang.ClassNotFoundException: states.jar:libs.jme-model.jar:libs.lwjgl.jar:libs.lwjgl_util.jar
	at Method)
	at java.lang.ClassLoader.loadClass(
	at sun.misc.Launcher$AppClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(
	at java.lang.ClassLoader.loadClassInternal(

Implying that it doesn’t like those : 's after all… :-\

maybe it is because of the space between :libs/jme-game states.jar:

Worked great for me. Great gfx. Game play was a little on the simple side, but awesome job for the amount of time.

Good call, I didn’t see that.

Yup, that did it.

java -Djava.library.path=./native_libs -classpath libs/rocky.jar:libs/jinput.jar:libs/jme.jar:libs/jme-ogrexml.jar:libs/jme-awt.jar:libs/jme-gamestates.jar:libs/jme-model.jar:libs/lwjgl.jar:libs/lwjgl_util.jar org.tomtro.inpool.Inpool

Although amusingly enough I have no right control so I still can’t play on this computer. ;D I’ll plug a keyboard in later.

I was finally able to play it - got 1704 the second time I tried.

The gameplay is a little too simple for the length of time it lasts - either make it a bare bones game where you only have to press like three different times, or increase the complexity, maybe making it like Simon Says or something. Basically the build up was not worth the payoff.

thumbed down

original idea

two security popup
no sounds
long loading before start
not polished