Re: Multiple GLCanvas on one JFrame

First of all, thanks for investigating the problem :).

So it should be the whole VirtualUniverse, that must not be shared with two views ??? What could a BranchGroup have to do with sharing texture memory. What do you think?

btw. Which version of xith do you use?


I am using Xith 8.0 version and now i am trying to shift to new 9.0 beta …but lot of code is tied up with older
version and so it will take some time to shift to latest version.

I was having this problem in older version of Xith but surprisingly it works with Intel graphics card of 3 series but not the latest.

Hi this problem is coming in Xith latest release 9.0. also

i tried to run org.xith3d.test.ui.FourViewsPanelTest
On a Windows XP with Intel Graphics Card : verson -

Now just try to resize the panels.

The application crashes with this exception.

# An unexpected error has been detected by Java Runtime Environment:
#  EXCEPTION_ACCESS_VIOLATION (0xc0000005) at pc=0x036e4938, pid=3768, tid=3252
# Java VM: Java HotSpot(TM) Client VM (1.6.0-rc-b104 mixed mode, sharing)
# Problematic frame:
# C  [ialmgicd.dll+0x84938]
# An error report file with more information is saved as hs_err_pid3768.log
# If you would like to submit a bug report, please visit:

i tried this other graphics card in 6.14.10 4series and same exception is coming but surprisingly , this works fine on
6.14.10 3series graphic card .

Oh, these HotSpot error lag >:(. They don’t say nothing for me. But you can maybe use the for googling for the problem.

Anyway the application doesn’t crash on my system.when I resize the panels. Please make sure, that it really does it for you. As I said, it crashes (or does other strange things) when the fourth frame (not panel) is to be rendered. You can see

in the console and the when the “4” is up to be dumped, the strange things start to happen (or a crash).

Is it like this?


Well on my working m/c this test example is working fine ,
i mean no problem with fourth frame .

The problem comes when i use on newer m/c with updated graphics card.
That also not with fourth frame getting rendered but only if you resize the panel etc.

As it is not happening on your m/c , please send me your system details with what graphic card you are using.

This problem does not come when different scenes are rendered on separate canvases , so that means it is because
of some illegal sharing of memory .

:smiley: yaa these error doesn’t say much , i googled for this problem and initially my reaction was that this problem is with
Swing integration with Opengl , and so i tried this on Java 6.0 also .

i am able to render multiple canvases in JOGl but when i use Xith for rendering than this problem comes .That too
when we share the scene-Graph .
So now i think i need to see how the same scene is rendered to multiple canvases and lets see what we can find ?

Linux Machine:
Athlon64 3000+
Asus A8V Deluxe, VIA K8T800Pro
1GB Kingston Dual Channel
Saphire Radeon 9800 Pro
Kubuntu Linux 6 Dapper, Kernel 2.6.15-27-386
Java 6 (same problems with Java 5)

Windows Machine (don’t know exactly):
Athlon 1800+
NVIDIA geforce 6xxx (or so)
Windows XP SP1
Java 5

btw. What is an m/c?

Cool, then you may know, what we are doing wrong in Xith…


;D sorry for being lazy , i intended Machine .