No lwjgl64 in java.library.path

Pulling my hair out trying to solve this…
Using IntelliJ to try and compile some Java code, but keep getting:

java.lang.UnsatisfiedLinkError: no lwjgl64 in java.library.path

I’ve tried adding lwjgl64.dll to my system environments, and I’ve tried created a ‘libs’ folder in my project and copying the .dll there, as well as setting my VM options with:

 -Djava.library.path="C:\Program Files\Java\lwjgl-2.9.3\native\windows\lwjgl64.dll"

No luck… Why is this so difficult to setup?

You need to point the java.library.path to the folder that contains the .dll not the dll itself.
I would suggest you have a read of ‘Getting started’ section of the LWJGL2 wiki.

LWJGL2 is no longer supported and probably broken in many ways on modern systems, I would suggest you switch to LWJGL 3. In LWJGL3 the natives automatically get picked up when you add the natives jar and you don’t have to point to them like in LWJGL2.

Sigh… I guess people will keep asking how to setup LWJGL 2.x natives in the next thirty years, no matter which major version of LWJGL is going to be current then, just because they started their LWJGL journey with YouTube videos from fifty years ago.

I would be happy to use LWJGL 3.2.3 - but the code I am messing around with utilizes stuff from .util - which has not yet been updated for 3.2.3.

If you have some tutorials that utilize 3.x - I’d be happy to look at it.

but the code I am messing around with utilizes stuff from .util

What exactly from util?


Currently - ArrayList, WaveData, HashMap, and Hashtable

I will check it out, thank you

ArrayList, HashMap, and Hashtable come from java.util, only WaveData comes from org.lwjgl.util.