I am trying to make a little game with Libgdx. I come across a huge problem. I have no idea how to name my interface, which would contain 3 methods: onPause, onResume, onDispose.
How would one name such interface?
I am trying to make a little game with Libgdx. I come across a huge problem. I have no idea how to name my interface, which would contain 3 methods: onPause, onResume, onDispose.
How would one name such interface?
It could be something like StateChangeListener or UpdateListener. Is it really that critical of a question though?
Not sure if troll post…
Its supposed to be used to register textures of various types (font textures that get generated on the fly, textures that need to be loaded manually from disk) in my extends ApplicationAdapter class. I just can’t come up with a good, crisp name for it.
For now I will just stick in ApplicationStateListener
Personally I’m always renaming huge swathes of my code because I come up with better names. The joy of working on your own with an IDE is that you can do stuff like that.