Game Entry: Epic Inferno. Epic win! :)

Hello guys!

Right now I’m a bit stressed because my game wasn’t approved this night and I need to go to work! :wink: The game itself is pretty big, but with Compile 'n Shrink it became under 4k. However, the generated pack-file havn’t been approved and I wonder if you have tips how to get it to work.

You can play the <4k version of the game here:


Was in the same boat last night, eventually got this working by renaming the resource 9f77… pack.gz to x.jar.gz and using a similar tag to the other games.

Having some trouble with the input under linux

Thank you for your reply!

I got some help and it works now. Here is how we did it:

  1. Renamed the file to epicinferno.pack.gz

  2. Made this applet-tag:


Sorry but it should work perfectly. The applet is using Keylistener and matches the provided KeyCode against each players stored KeyCodes.

Try it out here:


It’s been published.

It’s an Epic step in Epic Inferno’s history.

The input doesn’t work in linux for me either. (Ubuntu 9.10)


Darn, that’s no good. Maybe I should have used “processKeyEvent(KeyEvent)” …

I’m also running Ubuntu 9.10 and the problematic JRE version 1.6.0_16.
About 50% of the submitted games have some type of problem on this system :slight_smile: (More on this at,21626.msg181270.html#msg181270)

I had the same problem with BoxBot4k under Ubuntu 9.10.
Have you tried setting the focusable state of your applet to true? I hope it may help.
See also:


I think it is to late now, but sure I can try!

Epic Inferno was converted from old C++ code this weekend, so there was only time for shrinking it :slight_smile: Also, OS in Vancouver took some time from upgrades of the game :slight_smile: