Dust : The Abandoned Land -- Released after ~ four years of development!

Let me present you the game I have been developing these last years in my spare time: Dust : The Abandoned Land.

The game is still in its early development but as of today, it is playable and (I think) enjoyable.

Dust is a multiplayer real-time roguelike where you try to survive in a post apocalyptic world filled with oversized insects. To do so, you will have to fight creatures, survivors, and to create/integrate/manage alliances. Dust started as an experiment on a few gameplay ideas: For example, the character you play is no different from the other NPCs. Like you, they need sleeping, eating, warm, and they are only aware of what they can see or hear (see old blog posts: http://blog.mathieu.guillame-bert.com). Each creature has its own representation of the world and affinity/relation with other creatures. The ones with high intelligence (e.g. humans) are able to communicate, collaborate, or help each other. Dust has, I hope, a very unique gameplay “flavor”.

The game is made in Java using a custom engine based on LWJGL and Paulscode’s sound engine. For the development, I used Eclipse, Photoshop, Audacity, and LibreOffice Calc (for the mob stats tables).

You can try the game at dust.mathieu.guillame-bert.com. The game is free and runs on Window, Linux and MacOs.

Of course, here is the trailer:


, and some game screenshot:

(More screenshots are available at http://dust.mathieu.guillame-bert.com/gallery).

I hope that you will enjoy discovering and playing Dust. And, at the same time, and if you feel motivated, I hope you will send me feedbacks to help me improve it :).

wow 4 years project and still continuing. The game is good and keep it up. ;D
I didnt get far playing this game

Did not have much time to experiment, but among others, the controls seemed a bit uncomfortable. I would expect “Enter” key for confirming an action for example. Further, some actions can be done using mouse, other like “Throw item in hand” cannot be done, which is a bit confusing, otherwise good job, I will try to play a bit more once there is some time for that. Keep it up!

Thanks both for the comments :).

The game is expected to be hard (this is a roguelike :slight_smile: ), but the player should understand why he/she died, and how to avoid it the next time.

Can I ask you how did you died? and did you understand how to avoid it next time?

The “enter” seems to be an issue with people. I’ll do something about it in the next release.

Regarding the use of mouse, the idea is to allow playing on a couch with joysticks. My concern was that by allowing the mouse, players would have hard time transitioning to joysticks. What about freezing the time (like when in a menu) when the player is aiming a throw?

I like that you have a working launcher, it works great and feels snappy.

The game also starts quickly and impresses me in how much you implemented already, especially how you can interact with basically anything, really nice.

I could easily see myself playing this if it wasn’t for the controls, NuclearPixels expressed in a very polite way. The keyboard+mouse controls are absolute stinkin garbage, holy shit my brain feels digitally raped from trying to adjust to these controls man, this is the epitome of counter-intuitive and clunky. And this goes for the menus as well as the world interaction.

Here’s the standard input mapping from my point of view:

  • MOUSE AIM -> Looking, aiming and throw-placement
  • MOUSE LEFT CLICK -> Attack/throw
  • MOUSE RIGHT CLICK -> Alternate attack function
  • WASD or ARROW KEYS -> Movement
  • ENTER or SPACE -> Select in menus
  • ESCAPE or RETURN -> Return/abort/exit in menus
  • E or F -> Interaction with world objects
  • I -> Inventory
  • TABULATOR -> Tasks/Info

With “X or Y” meaning both should work for the same task.

[quote]My concern was that by allowing the mouse, players would have hard time transitioning to joysticks.
I bet most players will start the game with mouse and keyboard for the first time and maybe if they like it they will go as far as plugging in a controller. You’re pissing off potential players right at the beginning, do you think they will continue playing if the controls feel awful already? They need to feel at home right off the bat.

[quote]What about freezing the time (like when in a menu) when the player is aiming a throw?
Sounds like a good solution, you can’t really do this anymore in multiplayer though but i wouldn’t worry about that since you can still use some other scheme in multiplayer.

Don’t be mad though, it’s basically just the mouse+keyboard input scheme that’s bad, i really liked the rest of what i experienced so far, i started with tutorial but stopped at the part where you learn about food, i was completely fed up with the controls at that point :smiley:

Some things I noticed as I played:

You probably wouldn’t even notice it if you play the game like a normal human being, but if you are deliberately trying to find bugs, the movement keys behave a bit iffy.
If you press the down key, the character walks down. If I then press the up key while still holding the down key, the character walks up. If I then let go of the up key again while still holding the down key, the character doesn’t do anything anymore.
I guess there is no real answer to how it should behave because expectations will differ from person to person, but I’d personally expect that if i hold down an arrow key the character should move in that direction. It shouldn’t matter what I pressed before (like in the example). And if I hold down two opposing arrow keys (left and right, or up and down) it cancels out and the character doesn’t move.
Similarly, the striking with the axe. If my axe is swinging and I press the G key just a little too early (while it’s still swinging), it doesn’t swing again even though I’m pressing the G key. Would be great if the game recognizes that I’m pressing it and queue it for the next attack.
Might seem minuscule, but I think that something fundamental like the movement and combat which are used constantly, should work to perfection.

This is just my stupidity, but it took me like five minutes to open that first door. I just grabbed the first key, not realizing that there are others, walked up to the door and tried to open it. Of course that didn’t work, so I figured maybe I have to hold the key in my hand. So I opened the inventory and tried to unequip the axe, but it would not let me do that because “Cannot unequip item”. I got around that by dropping the axe instead, and I could put the key in my hand. Still didn’t work of course (wrong key) so I walked back to the room with the monsters in it because I thought maybe it would open that door (it didn’t). Back again to the room with the keys, I reread the tutorial message, and ah, “try to find the right key”. Sometimes when I watch livestreams and the streamer can’t figure out how to do something obvious despite there being a message telling them exactly what they have to do, I think to myself how on earth did they miss that. Well yeah…
Anyways, I grab the other two keys and of course the door opens. Now when I want to pick the axe up again and store it in the inventory, it says “No room in inventory (2.00L)”. Now that’s a better error message than the “Cannot unequip item” that I got earlier, because it actually tells me what’s wrong. But I still don’t understand why this is happening: The axe has 3.00kg weight and 2.00L volume, while my inventory can hold 50.00kg and 3.00L or even 6.00L if I put on the pants and shirt. What gives? After playing the actual game, I think I understand this now. The clothes I’m wearing have different volumes, with the biggest having 1.50L, so the axe doesn’t fit in any of them. Took me over an hour to figure this out, but maybe it’s more obvious to others.

Moving on. When I try to light the torch in my inventory it tells me “You need to equip the torch first”. That’s cool and all, but then it throws me back out and I have to reopen the inventory and find the torch again. Would be more intuitive if it sends me back to where I was -> in the inventory having the torch selected. Or if you want to do one better “You need to equip the torch first. Do this now? -Yes -Now”.
So I opened it back up, selected the torch and tried to equip it. “Cannot store the item in your hand”. I now know that I have to drop the axe first (because the game is trying to unequip it, which it can’t) but the error message doesn’t tell me that.
I also noticed that I can unequip the torch, and it will remain “on” in my inventory. So why couldn’t I light it in my inventory?

“There is a survivor guy living alone around 0 meters to the east” hah

I don’t know if this was supposed to happen but the barrels at the end killed me :confused:


A spider attacks me right away. I try to defend myself but the fists… they do nothing. I run away in fear and grab a couple empty soda cans and a dead fly on my way. I enter a building and find a journal which reads “The president Mr. Kardof was filmed punching a journalist in the noize. …” I do not know what a “noize” is, so I figure the journalist must have been a mutant.
I raid the pantry and stuff my pockets with candy bars, cereal, and a burger. I also find a map which shows me that I am in Summerwick. What a lovely name. I stumble into what appears to be a class room. I conclude that I must be inside a school. There are two books on the floor, one teaches me how to make a rabbit trap, and the other how to make a timer dynamite. What a strange school.

After some looking around I leave the building. Big Mistake. A flock of spiders immediately chases after me. What is it about me that enrages spiders so very much? I run as fast as I can and make my escape into another building. I look through a window to check on the spiders outside, fearing they might be able to open the door, but am instead greeted by a green projectile flying towards me and breaking the window. Fuck. The spiders might not be able to open doors, but they sure enough can crawl through an open window. Once again I run away and find shelter in another building. This time what seems to be a liquor store. I take a swig of alcohol to calm my nerves, and manage to find two soda cans and a bottle of water. Stocked with food and drink, I decide to leave Summerwick. It’s been a pleasure.

I walk south through the woods and soon reach a road. A sign tells me that “Wellwood” is 1.5km west, so I make myself on my merry way. As I walk I hear the sound of what seem to be car engines, but there are none. Am I going insane? I see another sign that tells me that it’s only half a kilometer now. Almost there.
Before I reach my destination, I find a journal on the middle of the road. “Science confirms: Dolphins have assholes.” A last message to taunt me before I die. For darkness fell, and I never reached Wellwood. Only gleaming red eyes over venomous fangs that gnaw me to death.

The end

Overall you’ve got a solid game going! I didn’t find any actual bugs, all of the things I critiqued are usability related. The game is already worth checking out, but if you polish the usability aspects and interface so they make the players life easier instead of harder, it will be even more so.

You certainly inspired me to keep working on my game, so thank you very much for that :slight_smile:

NuclearPixels & VaTTeRGeR
Allright, you convinced me. Let me work on the controls. Thanks for the returns :slight_smile:

As an immediate fix, I just added the possibility to configure individual controls (instead of the templates).

Support for the mouse will be in the next release (there is a bit more work).

Thanks a lot for the all blokers related to inventory management (and the spelling mistake, and the weird keyboard behavior, etc.)! This is the kind of things I cannot see anymore.

And yes, the barrels are expected to kill you :slight_smile: (I’ll add a little message).

Cheers :slight_smile:

Congratulations to the release, a lot of work seems to have gone into this project.

There’s a lot of detail and depth in there (didn’t play too long though), very nice. The mood is also very fitting, you really get this feeling of isolation, need for survival etc. :slight_smile:

The standard controls are absolutely horrible to be honest, just as @VaTTeRGeR It would be much better if they were similar to other games and user interfaces. This makes you insecure in stress situations where you quickly want to hide in a building and have to remember which sequence of keys you have to press to e.g. unlock, open, close and lock a door.

But overall - good job.


Thanks again :). And I am very happy you enjoyed the atmosphere.

Regarding the controls, do you have in mind an example of the default key mapping that would be better suited.

For reference, the available keys are:

  • Action - use the item in your hand.
  • Interaction - use the item/interact with the person in front of you.
  • Inventory - open the inventory menu
  • Cancel - Close any open menu
  • Running - Run (:
  • Aiming - Target the closest mob in front of you.
  • Favorite - Cycle though your favorite items.

And here is the default (current) controls.

Looking at some other games that don’t use the mouse, default controls in games sometime include ctrl/alt/shift/space, but I generally don’t like that.
Another type of controls I have in mind is the x-z-s-a.

A mapping using the xwsa (while keeping the same action structure) could be:
x : Action
z : Interaction
a: Cancel
s : Favorites
shift : Running
space: Aiming
ctrl: inventory.


I released the version 0.1.2 of the game :). This release makes the character control easier (this was needed), fixes a couple of bugs, and introduce a few new items.

Here are two examples of the new camera systems (camera consoles allow to player to see through the lens of the connected cameras).

Hello there,

Today’s I released the version 0.2.0 of Dust : The Abandoned Land. Among other things, I added support for the mouse i.e. ZQSD+mouse. This makes the game feel more fluid and probably more familiar for many players.

As always, the game can be download at https://dust.mathieu.guillame-bert.com/.

Cheers :slight_smile: