Bug War!

Here you can see me frantically trying to run my last marine back to base. That big guy in the back of the swarm just dragged the last guy in his squadron into the horde of bugs. Needless to say, I’m about to lose this round.


  • Two playable races!
  • Mining! Base building!
  • Ten (very) different units!

3853 bytes, all that’s left is making levels and little GUI touches.

EDIT: It’s much prettier now, go look a few posts down for that. But more importantly, you can play now!

oh nice a RTS, look forward to playing this.

yeah cant wait to try this.

Currently I’m at 3868 bytes. I’ve got a fairly comfortable margin to add little flourishes, like some extra GUI functions or perhaps some really shiny textures and shading for the units. Try it out!


no cigar!

I got this excpetion

Java Plug-in 1.6.0_17
Using JRE version 1.6.0_17-b04 Java HotSpot(TM) Client VM
User home directory = C:\Documents and Settings\Owner
c:   clear console window
f:   finalize objects on finalization queue
g:   garbage collect
h:   display this help message
l:   dump classloader list
m:   print memory usage
o:   trigger logging
q:   hide console
r:   reload policy configuration
s:   dump system and deployment properties
t:   dump thread list
v:   dump thread stack
x:   clear classloader cache
0-5: set trace level to <n>

load: class B.class not found.
java.lang.ClassNotFoundException: B.class
	at sun.plugin2.applet.Applet2ClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager.createApplet(Unknown Source)
	at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)
Caused by: java.io.FileNotFoundException: C:\Documents and Settings\Owner\Local Settings\Temp\Temporary Directory 1 for BugWar2[1].zip\B\class.class (The system cannot find the path specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(Unknown Source)
	at java.io.FileInputStream.<init>(Unknown Source)
	at sun.net.www.protocol.file.FileURLConnection.connect(Unknown Source)
	at sun.net.www.protocol.file.FileURLConnection.getInputStream(Unknown Source)
	at sun.plugin2.applet.Applet2ClassLoader.getBytes(Unknown Source)
	at sun.plugin2.applet.Applet2ClassLoader.access$000(Unknown Source)
	at sun.plugin2.applet.Applet2ClassLoader$1.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	... 7 more
Exception: java.lang.ClassNotFoundException: B.class

Very sleepy so I’m unsure of this, but it looks like you tried to execute it from inside a zipped directory. That breaks most things.

Runs great for me. I’ve only played the first level, but I’m definitely impressed. You managed to get AI and everything in there. Very very cool.

that would make a lot of sense, I will try extracting it now

Just tried this and got through the first couple of levels without difficulty. I like this. Need to read instructions more carefully though as I’m making rather random commands :slight_smile:


It’s alive! Enjoy.

So, does anyone have a favorite unit or strategy?