An Asteroids-Like Shooter Called Core Shot

Here’s a link to a download of a jar.
A target shows up in the middle you need to shoot to move onto the next level.
Sometimes you need to shoot enemy ships for the target to show up.

-Use the arrow keys to move.
-A and D to rotate.
-Space to shoot.
-S to stop with air brakes around level 6 and W for a force shield around level 8.
-Sometimes you need to minimize and maximize the screen to regain control of the ship.
-You can save the level you are on with a save menu in the upper left corner.
-The last level, which is 10, is glitchy, but if you quit and restart the level it is fine.

Still working a bit.

If anyone knows how to upload a jar to a webpage, so you can just click a link to play that would be awesome.


I think there is a problem with the downloadable file, the access seems not to be public.

Ok, try now.

  • Downloaded jar successfully
  • Typing java -jar coreshot.jar (With openjdk 11.0.5 2019-10-15)
  • Clicking on the “start” button
    ==> The two blue buttons get white, and I have the exception : D:\pics\blue_sound waves\music\ComTruiseUsurper.wav (The system cannot find the path specified)

Ok I will fix that. It still plays right? Just without sound.

I think it plays if you just click the jar and don’t run it from the command prompt.

You have hardcoded absolute file paths in your class files… this will definitely not work.

zipgrep 'D:\\pics\\blue_sound' coreshot.jar 
com/nigel/soundwavesgame/Level5.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level8.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level4.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level2.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level6.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level10.class:Binary file (standard input) matches
com/nigel/soundwavesgame/BlueSoundGame.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level9.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Rocket.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level7.class:Binary file (standard input) matches
com/nigel/soundwavesgame/Level3.class:Binary file (standard input) matches
com/nigel/soundwavesgame/objects/Target.class:Binary file (standard input) matches

Yeah, just on the background music though. I am pretty sure I have the problem fixed. Try again, if you want.

I turn on the game and clicked start. After a second or two I hear some music, then the UI goes blank. No errors in console :clue:

Did you try to minimize and then maximize??

Ah that fixed it. Game runs a little fast on my computer. I assume it’s not delta/timed or framerate capped?

No, its not. It runs fine on mine. I might look into delta and framerate caps, especially if others complain.

Thanks for the feedback.

I know it runs fine on yours, because you designed your game to run specifically for YOUR cpu.

It does feel like the spaceship moves a little too quick. What kind of game loop are you using if updates aren’t capped?

Its on a timer that updates every millisecond and the ship is set to move 3 pixels in any direction every millisecond.

I tried different combinations of update times and pixels moved but this seemed to work for me.

For example, the animation in the background is on a separate timer that updates every second.